Jump to content


Photo

Canon S20 Lens Error


2 replies to this topic

#1 SydneyTez

SydneyTez

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 27 January 2012 - 02:03 AM

Canon SX20 bought end 2009 and out of warranty. Since April 2011, getting intermittent lens error where on zooming, the lens goes in & out a few times then shuts down. On restart sometimes works. If not, leaving overnight & camera ok. Have tried following: 1) Resetting to Canon default settings- sometimes works 30% 2)removing batteries when switched off -still lens error 3) leaving on, removing batteries, leave for hour - fixes problem for a while. 4) Tapping case where hdmi etc are on palm of hand - seems to work for a while 5) I have replaced batteries, rechargeables & Alkalines but that does not have any impact on results. I do not wish to send it into Canon as the likely repair costs will go a long way to buying another camera

My questions to you are:
a) Could this be an electronic rather than say dust problem within mechanism
cool.gif Is their a firmware update for this camera and is it user installable
c) Any other suggestions on fixing this camera





#2 iibattery.com

iibattery.com

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 28 January 2012 - 08:07 AM

Is AF-driver problem ?
I am a professional photographer based.nikon battery and charger,keyboard store

#3 SydneyTez

SydneyTez

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 February 2012 - 12:53 PM

QUOTE (iibattery.com @ Jan 28 2012, 07:07 PM) <{POST_SNAPBACK}>
Is AF-driver problem ?


Hi,
can you please explain further about AF driver problem

we normally keep to auto mode or P(rogram) mode to use the super macro function
Could only find the following menu options:
under auto mode, we have the AF assist beam set to on
under P mode, we have Servo AF set to off, Continuous AF set to on, AF assist beam on.

thanks




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users