Jump to content


ljcybergal

Member Since 27 Mar 2005
Offline Last Active Sep 01 2006 07:53 PM
-----

Topics I've Started

Epson P2000 Firmware Upgrade Problems

27 August 2006 - 12:49 PM

Hope someone can help. I have just tried to update my Epson P2000 from v2.02 without success. Last year sometime I updated to v2.02, at least the Settings screen said so (although I've only just realised that strangely, the folders in the Saved Data folder were not displayed separately according to date, they were still grouped together).

Today I downloaded the v2.04 file from the US site and attempted to upgrade first to v2.04, before upgrading again to the latest version 2.51 (this is what the pdf file recommended). I followed all of the instructions and everything worked fine, except on powering on and going into Firmware Update mode, the screen said "updating to v2.02". On completing the update and restarting the unit, the Settings screen still showed v2.02, not v2.04 (although I now have the separate subfolders in the Saved Data folder).

I then went to the European Epson site and downloaded the exe file for the 2.51 update, since they make no mention there of having to update first to v2.04. I tried updating again and the same thing has happened, I seem to be stuck with v2.02. I've searched on Google and can't find anyone else with the same problem.

Any ideas anyone? I just bought a 2gb SD card and wanted to start using it in the P2000, and I understand that in order to do this I need to upgrade to firmware v2.51. HELP!

Thanks, Lisa.